Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Z probe issues
#1
I have been able to flash the eeprom of the xyz printer that I have been working on for a few months now. I used the latest bin file that had the mods for z-probing. I used xyz software to write new firmware to the printer. Now I have made the move to using RH to run the printer. I have started my first print today but will not see results till tomorrow.

I have flashed the filament cartridge in the past and have been working with using Slic3r to generate the gcode files, then copy them to the SD card and printing them through the printer menu.

I have made changes to the setting of the eeprom in RH, the only issue I have not been able to make work properly is the z-probing, it does not move after touching first measuring point. I am sending g32 s2 to the printer and the pin makes contact with metal clip but does not move to next location. The clip and extruder pin are clean, so I was looking for possible troubleshooting advice on this issue. I am very interested in getting this feature working if possible.

Also I was interested in suggested extrude and retraction speeds in the manual control window of RH and for Slic3r as well. I have notice what I suspect is issues related these setting and was in need of others opinions of what these setting should be.

I am very happy with the changes and look forward to contributing any information I can to making the xyz printer do what some of the high dollar printers can't do.
Reply
#2
The bed leveling failed in the Rep Host. when I switched to the Pronterface, the bed levelin still failed, but when I did it manually, it printed with little or no issues. I still have yet been able to get the rep host to work. It seems to ignore the printer. The baud rates are good as I am using the same ones in Pronterface.
Reply
#3
I'm using Keith's eeprom and config.h adjustments to attempt z probe in RH as well. I get the same issue. The head touches off at the first point but does not continue. It actually reaches the max z-probe distance and then stops and does not continue to the other points.

Also, I experience intermittent errors on the x-axis control. Sometimes it can't home, but a few seconds later it usually works.
Reply
#4
I re-flashed the firmware Keith uploaded recently and cleaned the bed contacts with alcohol. Now the bed leveling completes, but it compresses the springs slightly during the z probe.
Reply
#5
Regarding the Z probe - Once it hits the first pad does the build plate continue to go up past the point of touch? If so, the pin or contact is not perfectly clean. If it touches and then immediately stops, then most likely you have some setting "somewhere" wrong.


Kieth
Reply
#6
Kieth,

Yep. I went at the extruder/probe with the wire brush and now it works probes great. As soon as it makes contact the z-axis backs off and the probe moves to the next corner. I guess it has to be a little more than "visually" clean. Running my first test print.

I still have the x-axis problem every once in a while, but not often.
Reply
#7
I loaded the latest firmware yesterday, loaded in the drivers and ran repetier host. I put in Kieth's adjustments for the eeprom and RH, but when I try to print something, the bed doesn't move down far enough to start the print. The leveling button hits the side of the glass on the bed and I have to quickly shut off the printer.

Is there something that I am missing in setting this up?

Thanks,

Joe
Reply
#8
You have to move the Z down 10mm before you start the auto level. after auto level start your build. I have not tried with the latest bin from BGM. I will try later tonight or tomorrow to post my bin and setting as one "set".

Kieth
Reply
#9
I did that and it sets the offset, but when it starts printing, it seems that there should be an offset for the bed that is missing.
Reply
#10
Joe - Im guessing you are moving the Z after the bed leveling procedure.

In slicer config settings under "printer settings" / "custom g code" try adding this:

M140 S90
M104 S210
g28
g1 z10
g32 s1


Then add this to the end:
G1 Z198
M140 S0
M104 S0
M84

Note: Its possible to shift the bed a little during print removal or bumping it, the level procedure is very fast --- and so there isnt a real reason to use s2 to store the values to the eeprom or to not level every print. Just be sure to clean the pads and probe every print.

Kieth
Reply
#11
Well, it is now printing. I am not sure why, but the plastic is not sticking too well. I am using XYZ's black filament. I set the first layer to .32mm and that seemed to help.

Is there anywhere that anyone has the settings for slic3r?

Thanks for all the help. It is really appreciated.
Reply
#12
There is a post about using other slicers with xyz ware - and it contains the slicer settings you are after.

Kieth
Reply
#13
Again Kieth,
Thank you for the response. I didn't realize the machine would have to run as slow as it is set up to do.

I appreciate all the help. I hope that one day I can return the favor.

Joe
Reply
#14
I was able to get my latest test of Z probing to move from the first test point to the second test point and stop. I have to guess at this time that maybe I needed to possibly raise the z axis a little more but ran out of test time.

Still struggling with some other minor issues involving quality problems, but to be expected with a $500 dollar unlocked printer.




Here is the latest print we have been able to produce using repetier[Image: DSC00262.jpg]
Reply
#15
Hey guys, picked a Da Vinci as my first 3D printer last week. I loaded the latest Da Vinci flavor Repetier firmware and currently can only get the first three z probe points. The front left is the last to be probed and once done it lifts from the 3rd point and goes into an idle. I don't see how the software could adjust the coordinates correctly
without the 4th height value so I assumed it wasn't making good contact and cleaned the probe with the wire brush a few more times as well as the four corners on the printing table with no luck.

I'm hoping the z probe calibration will help with my nozzle height because as of right now I seem to get different z axis values during prints with most not depositing the abs firmly enough to stick well. With XYZ software I had excellent results as far as the base sticking and not warping on my prints but I'm looking to try and bump up my finish quality with slic3r and be rid of the proprietary filament.

If the probing really only looks at the 3 values could my issue be some value in the emulated EEPROM settings I need to adjust specifically for my printers table height?

I have also noticed several bugs in the firmware like when I have to shut the printer down via the power switch, when switched back on repetier host will not connect and I must cycle power once more(I'm sure this isn't a port # problem either). Also homing a single axis can cause a crash if the Z axis was homed first(via repetier host). Few more small bugs in the display and probably some I'm forgetting but I'm learning to work around them for now, may attempt to adjust the code once I get a better understanding of setting up a 3D printer.

Appreciate any insight you guys might offer on the probing issue though.
Reply
#16
Quote:The bed leveling failed in the Rep Host. when I switched to the Pronterface, the bed levelin still failed, but when I did it manually, it printed with little or no issues. I still have yet been able to get the rep host to work. It seems to ignore the printer. The baud rates are good as I am using the same ones in Pronterface.

I realize your post is over 2 months old but if you haven't solved the connection issue yet I've found the one parameter needed to initially connect through repetier host was under Print Settings -> Reset On Connect = RepRapPro Duet Firmware.
Reply
#17
Did some reading on the vanilla variant Repetier manual and realized the z-probe is only 3 points.

I was still having issues with the filament not sticking though and ended up gorilla gluing the Z axis linear bushings into the right side of the print bed to the 2 attachment points(br ass bushings). I also cut and folded two long but very short pieces of paper and wedged them in between the edges of the glass and plastic print bed to alleviate massive slop that was waiting to cause issues with my prints. These two mods removed about 95% of the vertical and horizontal slop my print bed was seeing. There is no doubt it was shifting albeit probably slightly and only during certain circumstances.

Just about done printing a part I have been trying to perfect the finish of from day one and so far it's at leasy 20% better then any of the 5 others I have printed. I'm not sure if it's Repetier since this is my first full print with or if my mods had that much of an effect which seems more likely. I can tell you the filament is the same as well as the slic3r generated g-code.

Gonna play with it for a few more hours and maybe go get some acetone and see how good I can really get this stuff looking :evil:

Oh and I made a custom g-code start for slic3r I'll share later with comments on each step that are super clear for noobs and should help us learn the code quicker and easier. The start g-code is a butcher of forum members "Edouard" and "Keith" mixed with a few bits I added.

Appreciate all the work guys and the fact that you took the time to put the information out there for us!
Reply
#18
   
Di Vinci Jr.Broken Z axis senor wire harness / circuit board. How do I get a replacement part or repair the wire connection to the circuit board.?


Attached Files Image(s)
       
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)