Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I bricked my Da Vinci 1.0 3D Printer upgrading firmware
I bricked my Da Vinci 1.0 3D Printer upgrading firmware to 1.1.i. There are now 2 black bars across the LCD screen.
Is there a way to place the .bin file on the SD card? Or Some other method to place the printer in a boot loader mode?
Attached is a picture of the main Atmel chip ATSAM3X8E AU I can only assume the black connector is for burning the firmware when your machine is bricked?

Details from Atmel site [url=[/url]

Based on the ARM® Cortex™-M3 processor, the Atmel® SAM3X8E runs at 84MHz and features 512KB of Flash in 2 x 256KB banks and 100KB of SRAM in 64KB +32KB banks, with an additional 4KB as NFC SRAM. Its highly integrated peripheral set for connectivity and communication includes Ethernet, dual CAN, HS USB MiniHost and device with on-chip PHY, high-speed SD/SDIO/MMC, and multiple USARTs, SPIs, TWIs and one I2S. The SAM3X8E also features a 12-bit ADC/DAC, temperature sensor, 32-bit timers, PWM timer and RTC. The 16-bit external bus interface supports SRAM, PSRAM, NOR and NAND Flash with error code correction. The Atmel QTouch® Library is available for the SAM3X8E for easy implementation of buttons, sliders and wheels. The device operates from 1.62V to 3.6V and is available in 144-pin QFP and BGA packages.[Image: 20140510_0820561.jpg]
In the pictures In my Previous post I noted a 20pin black connector. This does appear to be a 20pin JTag for an Arm.

An interesting fact after further reading this is the same processor SAM3X8E as the Arduino Due.
It makes it very possible to completely wipe the Firmware and use an opensource 3d printer Arduino code.

However since I just want to get my printer working I think it will be easier to simply download Atmel Studio 6, which has full support for the entire SAM family. You will get a much more capable IDE, and a full-featured SDK. And, you will gain the ability to use a JTAG debugger compared to using Arduino IDE tools. And upload the stock bin file.
Atmel Studio 6 is free.

I need find a cheap programmer on ebay now.
Once I loaded Atmel studio my printer now shows up as a Bossa Program port on com15 in the device manager, it’s a step in the right direction. SO YOU DON"T need a Jtag
So I installed the Arduino IDE.

Once that is done you can
To simplify things I copied this C:\Program Files (x86)\Arduino\hardware\tools\bossac.exe to my C:\
I renamed the firmware file from XYZ to firmware.bin and copied it to the C:\
I made a batch file in the root of my C:\ containing the following text match your com port and your file paths.

c:\bossac.exe -p COM15 -U true -i -e -w -v -b c:\firmware.bin –R

open device manager and turn the printer off then on, and as soon as you see it show up in there runt he batch file. It will burn the Firmware to your bricked printer!
Your printer is unbricked! Feel free to send cash via paypal hehehehehe

After some googling [url=,300221,302988e

And yes we can load in open source firmware using this same method! Thanks for listening to me ramble and watching me think this through.
Jason Rollette
Yes, I've already pointed out the need for sam-ba to recover from a rock, and I detailed the buttons to not push if you don't want to reset the micro to oem. Wink

But- you can't just load another firmware. If you don't know the pinouts you could seriously harm the hardware. There are a few of us working on pinouts to make pen source firmware compatible.

Thanks for sharing your success. Smile

Edit: Fix androids auto spell and grammar ruining ability.

I made a mistake and bricked my Printer when I accidentally downloaded the firmware. I have followed all the steps listed here but I haven't had any success. My computer won't recognize my printer at all.
I am a bit of a noob.
Is there another way to reset the printer or go about remedying the situation?

Thanks for everything
Did you install the latest atmel studio and bossa drivers?
Does the printer show up in device manager? (Watch device manager as you plug in the printer and see if it shows up.)

If device manager shows bossa then you have the drivers and you need to follow this:
c:\bossac.exe -p COM15 -U true -i -e -w -v -b c:\firmware.bin –R

EXCEPT = c:\ will be the location of bossa.exe
COM15 will be the com post the printer connects as (found under device manager)
c:\firmware.bin will be the name\location of the firmware you want to install

Let us know exactly where you are getting stuck.

I installed atmel studio 6.2, arduino 1.5.6-r2 and sam-ba 2.12. I copied C:\Program Files (x86)\Arduino\hardware\tools\bossac.exe to c:\ along with a copy of the firmware i renamed to firmware.bin.
When I connect my printer, nothing changes in the device manager. Any thoughts?
Power the printer off. Connect jumper j in center of board. Power on for 5 seconds, then back off. Remove jumper. Turn printer on then plug in usb. Device manager should automatically find bossa device.

Be advised this erases the printers hours and serial number. As such, it may effect warranty. Search the threads for the commands to restore the serial number.

Thank you! I appreciate all your advice and guidance. My printer is no longer a brick.
I tried adding Repetier also and somehow I'm at the black bar point. Computer recognizes it as Bossa Program Port. When try to use Arduino I get a

" Sketch uses 10,380 bytes (1%) of program storage space. Maximum is 524,288 bytes.

Erase flash
Flash page is locked"

I used the "Noob Firmware" install way HERE
My board looks newer. Doesn't have the 3 buttons or the jumpers. Any help on getting my printer back online? :whistle:
Mine has no jumpers or the 3 buttons. How do I go from here?
For sake of gaining information please take as high a res photo of the board as possible.

Looks like it is still there, just not populated. It's marked jp1 right in the center of the board. You will likely need to use tweezers or something to join the pins during power up.

Curious, had their tech super told anyone how to reset the board or re flash from a failed upgrade? I suspect not, that instead they are swapping boards or exchanging printers.

Ooops, I just saw your other post with pics.

[strike]It may be that XYZ have upgraded/changed their boards.
When exactly did you get it?

Could you take some pics of your board?
Try and get a couple of closeups of some of the bigger chips also, so we can try and identify it, and see what exactly has changed.[/strike]
I tried the jump method and had no effect. When I ran Bossa "autoscan" it show it couldnt find a device. It recognizes something in a serial port, but wont allow me to connect to it or cant find it on autoscan.
Sounds like you are using the gui version of bossa. It also sounds like you might not have the correct drivers installed. You need to use the command line version included with the latest atmel ide.

Atmel installed alot of drivers automatically. Not sre exactly which one I need. Also, I tried this cmd line " C:\bossac.exe --port=COM8 -U false -e -w -v -b firmware.bin -R" in cmd and got "SAM-BA operation Failed"

This is as close as I've gotten to cmd giving me anything. Am I missing anything on the cmd? starting to go into deep waters with command lines...

Forum Jump:

Users browsing this thread: 1 Guest(s)