Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Filament counter reset
#21
Curious. Under settings do you have "auto feedback" enabled? It *might* be illegal (at least immoral and unethical) if they are sending that data even with the song turned off.

Suggestion: Add xyz to your hosts file and direct it to nothingness.

Kieth
Reply
#22
Im so glad you posted that about purple filament, I have been really struggling to recently to get any print to start well (not sticking). Tried everything, clean bed, little glue, tons of glue, but with no success (just went out and got some tape and my last option was to use acetone slurry with ABS dissolved in it), but looks like it was because I switched to purple filament.

I also tried switching back to G firmware and that didn't help. I really think the L firmware was just to block filament hacks and add tweak some features like nozzle clean.
Reply
#23
On the purple, I used ext temp 240, bed temp 95, no glue, no rafts. It sticks okay at the higher temps.

Kieth
Reply
#24
Quote:On the purple, I used ext temp 240, bed temp 95, no glue, no rafts. It sticks okay at the higher temps.

Kieth

And which method did you use for setting those ? Filament eeprom or slic3r ?

thanks
Reply
#25
I set all my cartridges except one to 240/95.. I then control temps through slicer. If slicer temp is higher than the cartridge the printing either takes forever to start or never starts. Also, with the higher cart temps I have trouble getting calibrate to start - hence one cartridge I install with stock temps in order to run the calibrate routines. I'm tired, so I hope this makes sense. Wink

Kieth
Reply
#26
got it Smile
Reply
#27
What tweaking do I need to do so that the reset code will run off of an arduino mega 2560? As it stands right now, the LED on the board will flash but it will never act like it's reading anything from the chip and nothing is written.
Reply
#28
The code is configured to use digital port D7 for the data line, which maps to digital pin 7 on the Pro Mini. D7 maps to digital pin 38 on the Mega2560, so try using pin 38 for the data line. (I used a teensy 2 by hooking up pin 14 for the data line.)
Reply
#29
So if I never updated the firmware and I wanted to still set it to 999, what would be the hex code using little endian in arduino form?

Been trying to find this posted with no luck, google searches provide little help. Any help is much appreciated.
Reply
#30
In python, you can compute the bytes with:

Code:
# create a little-endian string of hex-encoded bytes for 999000 (length is in mm)
hexval='%0.8x' % 999000
# Swizzle to big-endian order:
bytes=[hexval[i-2:i] for i in range(len(hexval),0,-2)]
# compose the assignment for x:
'char x[] = {' + ','.join(['0x'+s for s in bytes]) + '};'

which returns:

Code:
char x[] = {0x58,0x3e,0x0f,0x00};
Reply
#31
What happened to Oliver's blog writeup? Was gunna give it a go.
Reply
#32
This one? https://forum.voltivo.com/showthread.php?tid=7977

Kieth
Reply
#33
Quote:This one? https://forum.voltivo.com/showthread.php?tid=7977

Kieth

thanks, the one I bookmarked is gone
http://voltivo.com/blog/da-vinci-reset-eeprom
Reply
#34
I really need help. I followed the instructions and loaded the rest EEPROM sketch on my Arduino Uno. I reset the EEPROM but now my printer won't recognize the cartridge. It says "No Cartridge, re-install." I have tried every position to see if it was just that the chip wasn't sitting flat. It seems to be making contact. I have the chip in the correct orientation in the cartridge.

What am I doing wrong? Is my cartridge dead?
Reply
#35
There are a few possibilities.
1) if you are running the latest xyz firmware or if anything went wrong flashing the cartridge the cartridge might be corrupt. You'll have to search here for the info, but there is a thread where I tell how to reprogram the entire chip. You would need to downgrade firmware to 1.1.g or earlier and flash the cartridge fully to remedy this situation.
2) you might have hooked the data or power lines up incorrectly, destroying the eprom. This would require you to replace the in eprom and related completely
3) there could be contamination on the contacts, try gently cleaning them with a pencil eraser on both printer and cartridge side.
You can narrow down the problem by trying another cartridge.

Kieth
Reply
#36
Thank you for replying so quickly. I have the 1.1.G on my printer and the 1.1.30.9 Hotfix on my PC. It seems to print fine already. I think the problem is probably that I hooked up the lines incorrectly and fried the EEPROM. I have the wires in the Arduino Uno set up the same as Oliver's tutorial. I just didn't know which contact each one was supposed to connect to on the chip.
Reply
#37
I'm am new to this and I just want to use my own filament (exelfil).
I've read a lot about resetting the filament but if I buy this one http://www.wctek.com/shop/order will it work?
And how do I change the temperature?
Reply
#38
I would suggest doing the full jailbreak and then you can use repetier software to print, control everything and use whatever filament you like. bit of work upfront but if I can do it, anyone can,
Reply
#39
I purchased the XYZ pro. I love it! You use the arduino software and change the extruder temperature,heat bed temp,filament length. Extremely easy to use.
Reply
#40
once you have done the cartridge reset can you then just change the temperature on the computer?
Reply


Forum Jump:


Users browsing this thread: 3 Guest(s)