Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Repetier Firmware On 1.0A 1.0.3 J37 Motherboard
#1
Hello all,

So i just picked up my Da Vinci 1.0 2 days ago to flash the repetier firmware onto when I received the new mainboard. Out of the box it shows up as 1.0a/1.0.3. When I removed the back panel I discovered it has the j37 pin so this baby is rocking the newest mainboard. After digging through the forums I have gathered a great amount of knowledge but would like some clarification.

For one, it seems that with the new mainboards if you flash the latest beta repetier firmware there is no going back. Due to their being no dump of the correct oem firmware flashing back is not an option and flashing to an older software version isnt compatible either so again there is no going back. Is this correct?

Second, it does appear that bridging the j37 pins will indeed short/reset the microcontroller allowing you to flash it with repetier fw. right?

Now when it comes to the repetier fw available for the model 2 board. It appears the lcd has issues along with the monitoring of temps meaning there is a risk of overheating/damaging components. Is this also true?

Lastly does anyone know of the status/level of people working to get this all up and running smoothly like it did on version 1 boards? I am not a programmer but have a machine that I would love to help with if possible.

Thank you all for your time and help!
Reply
#2
https://forum.voltivo.com/showthread.php?tid=8224

They have repetier adapted for the 1.0A. There's an instructions.md file somewhere in there, read it because you have to do some stuff to make it work. My Z sensor still doesn't work, so I disabled it from checking the axis before printing in the "configuration.h" tab.
Reply
#3
My 2 cents - those of us involved with the initial 1.0 board of course don't have the version you do, so unfortunately there is no way we can troubleshoot the issues like z stop. If someone with the board can physically trave the pins of the z stop back to the micro then it might be possible to generate test files if someone is willing to test. Doing so is not without risk, any error could potentially damage the board. (My suspicion is the z stop either has a different pinout or it is inverted.)

Really, the same applies to trying to dump the firmware, without a board it isn't possible, and might not be possible even with aboard depending on how bits are set. So, until xyz updates the printer while someone is logging the location of the file, well......


Kieth
Reply
#4
Am I understanding this correctly, We still don't have a 1.0.3 firmware .bin? If that is the case my 1.0A came with fw 1.0.1 then updated to 1.0.3 and it dropped the new firmware .bin file in my application data of the xyzware.

I've attached the .bin file in case somebody needs it. https://forum.voltivo.com/images/fw-dvF1....3.bin.zip
Reply
#5
you will make many people happy with this ^_^
Reply
#6
Noob here...

I had the 1.0.3 version of the original firmware and took the plunge with the 0.92 FW and Repetier. I was able to flash the new FW by bridging J37, and it behaved as expected when I followed the directions on the Github page.

I did run into some issues:

1. Temperature table for extruder is not correct for my board, and my temps were showing as -20C and the thermocouple was showing up defective.

The result was that the extruder didn't heat. I used my hot air gun to warm up the extruder at first. Later, I dialed down the defective temp setting in Configuration.h from -10C to -30C, uploaded a new firmware and that has solved the problem. I will probably try to figure out the temperature tables at some point to see if I can fix it that way, which seems like less of a hack.

2. The LCD rarely initialized correctly. I found that a quick off/on usually fixed this.

I played with the initialization timings a bit and it seems to be better, but not solved.

3. Had some initial setup issues with Arduino IDE, but those were newbie mistakes.

I forgot to set the target board to Arduino Due, and it took me a while to figure out why the compile was failing.

4. Recently, I bought a Windows box for my Da Vinci (had been using my MacBook) and had a hard time figuring out why the COM ports weren't allowing me to connect to the DaVinci.

I had to install the FTDI drivers for serial over USB on Windows (it worked out-of-the box on the Mac)

I've been running this config for about a week now and am very pleased. Props to the firmware developers for coming up with such a nice solution! Smile
Reply
#7
Hi,
1- Thermistor issue should be solved - fix has been uploaded this week (check here)
2 - LCD initialization fix is on going and hope will be ok soon (check here)
Reply
#8
I was getting jumbled LCD display
Sometimes it was OK but didn't function
My LCD a problem from the beginning with ribbon cable being cut, but that was fixed and worked fine
under XYZ 1.1G firmware

Just flashed your 1.0.3 firmware
LCD blank prior to flash
LCD blank post flash

Didn't fix my DaVanci?

My controller board
has jumper pins
3 buttons in the middle
R3.1 in corner
EG41F1088

anyway of getting LCD working
:S
Reply
#9
1.0 and 1.0a are different boards and use different stock fw
If you used 1.1G before, you have old board, not new one
Reply
#10
Can anyone confirm that the firmware attached is the 1.0.3 If this is the case then I can definitely flash it back if the repetier firmware is to buggy correct? I am ready to flash and just wanted to make sure I could go back if it came down to it. Please confirm as I really want to give it a run but again am concerned with whether I will like it or not :lol:
Reply
#11
Yes this is 1.0.3 from a davnici 1.0a The file was dropped in ~/.XYZware on OSX when my da vinci updated from 1.0.1 to 1.0.3 My board has the J37 jumpers and the micro SD glued to the center. As well as having 1.0A displayed on the LCD after the 1.0.3 upgrade.

I have not attempted to flash back to it though since I switched to repetier and never looked back. Honestly I have no clue what took me so long to switch, I would say the control over the machine and quality of the prints I can get have easily added a couple hundred dollars to the value.

If you have OSX and XYZware 1.1.1 you will likely have the same files in ~/.XYZware/

Current Setup
Model: Da Vinci 1.0A
FW: Repetier .92
Slicer: Slic3r
Interface: Octoprint
Reply
#12
I was able to flash Luc's .92 Repetier firmware to my 1.0A DA Vinci. Everything seems to work fine, except the stepper motors are overheating about an hour into the print and started to skip steps. I'll try to look into it today.
Reply
#13
Evan - did you check the reference of motor is same as old generation ? should be 17PM-K342BP03CN
Reply
#14
hi Luc,

My motor in the far corner (stationary) says this: 17PM-K142BP03CN
The motor that moves the carriage says: 17PM-K342BP03CN
Reply
#15
Ok same as mine - and Z is another on 17PM-142BN06CM
which motor is missing steps and overheating one or all ?
Reply
#16
Just the 17PM-K342BP03CN that's moving the carriage. It's extremely hot to touch and the other motors are almost the same. Overall, the motors are running noticeably louder compared to the stock firmware. I'm not sure if it's the pot settings, acceleration, or what. Any insight you can give is greatly appreciated.
Reply
#17
well the sound difference is definitly the acceleration difference
For the temperature : drivers can be the root cause, they are soldered on 1.0A so hard to change.
if you disable steppers from printer menu and let printer for while, are motor also hot ? or this happen only when printing ?
Reply
#18
The motors are getting hot during the prints. I don't think they're getting hot when idle, but I'll check in the morning. I just changed the acceleration way down in the Eeprom and started another test print. We'll see if it makes any difference.
Reply
#19
I found this same file ( firmware.bin) on my computer and verified that it is the same exact file as the one on this discussion by doing a file compare command at the DOS prompt. I also found a firmwarelast.bin file. I was thinking that maybe the xyz software created a backup of the current firmware before it updates. I have tried to flash each of these these files to the printer using this at the command line "d:\bossac -p COM4 -R -e -w -v -b d:\firmware.bin after I copied the bossac.exe and the firmware.bin file to the D drive. The firmwarelast.bin does not upload successfully so not sure what to think of that file. The firmware.bin file that is the same as the one linked on this discussion does show a successful update to the 1.0.A printer but when I power cycle the printer I just get two black lines on the lcd screen. I also get "unknown device" in the device manager. Not sure If I am missing something here so any ideas would be appreciated.
Reply
#20
I could use some help getting the .92 to work in my 1.0.A printer. I've "successfully" flashed the .92 version to my 1.0A printer but I get two black lines on the screen when I power it on and then I get "unknown device" in the device manager. I've tried adding the variants.cpp file as some suggest but the Ardunio software throws errors when I try and compile it with that file attahed. Maybe I'm not doing that part correctly.... See attached screenshot for reference. I do have the samba 2.14 installed. and I've tried to add the driver from Atmel to "unknown device" but it won't take. Not sure what to do at this point - any help would be appreciated. No matter what I do I have two black lines on the screen. I can't flash my printer back to 1.0.3 and have it work or get Repetier to work so I have basically have fancy xyz printer that is only useful as a conversation piece at the moment.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)