Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XYZ 1.2.3 Firmware Downgrader App
#1
I made a little app to downgrade your firmware from 1.2.3 to J or G, your choice.

[Image: vO0W3hf.jpg]

Download: http://gcodeteleporter.com/Setup-XYZDowngrader.exe
Directions:
- Select COM port for printer
- Type in your serial number
- Select firmware version
- Click 'Downgrade' once you have prepped your printer

Let me know if you have any problems.
Reply
#2
Phil -- one word ...
BRILLIANT!

This will save so much time and frustration. Well done !
Reply
#3
To note you still have to jumper J1 to flash.

However, if the XYZ could flash from software without jumpering, I don't see why we can't. I'm going to see if I can figure that out. No promises. I just got my machine a week ago so it's all new to me.
Reply
#4
use old xyzware and downgrade to 1.1E so you don't have to do anything else to use 3rd party filament, Then use xyzware mod.
Easiest way to get what you want from Da vinci


Bill
Reply
#5
I was unaware. Thanks for the info.
Reply
#6
How is that a solution to a downgrade? You can not downgrade from 1.2.3 to "E" or any version with old xyzware or any xyzware -- you'll get a firmware error. The downgrade lock is not within xyzware but withing the firmware itself. You still need to jumper 1.2.3 to load any firmware.
Reply
#7
Quote: - Click 'Downgrade' once you have prepped your printer

Let me know if you have any problems.

Where are the instructions for prepping your printer for downgrade? What's this about jumpering?
Reply
#8
What are the pros and cons of G vs J? Which is easiest to run external filament? Flashing a cartridge shouldnt be a problem for me (I have an arduino), but having never done it, I don't want to break what was a sizable invest for me.
Reply
#9
Get all the instructions from this forums or from the download section on http://www.wctek.com/shop. It's all in there -- just use the new utility after you do the jumper reset - if the utility does not work, just use the guide in the zip file.
Reply
#10
J is the most updated, stable without remote disconnect/tracking/resetting and all that crap that XYZ introduced.

IMO of course.

P.S. We have been running J on all the 1.0 and the 2.0 printers here since it came out -- works without any issues. Having said that, on older boards, you may need to downgrade to G (G is also ok - no issue, but I think J has better arches - I will do a run with all firmwares and post a full review with the same print for everyone to see the differences in the next few weeks).
Reply
#11
any update on a software flash to downgrade to 1.2.J?

I'm leery opening up my printer and using a jumper..
Reply
#12
It is not big deal. The hardest was actually extracting the printer from the cabinet and all the spools around it. I am grateful for the extra weight lifting I had to do thanks to XYZ's forced "upgrade".
Reply
#13
Could you let me in on where to find 'J4' on the Duo 2.0? This is the jumper that needs to be shorted on the 1.0 to erase the flash. i've seen J1 and J2 on my dual fan Duo, but no other jumper locations visible.

UPDATE: I soldered headers to both locations, and deduced after more research that It's jumper J1 on the Duo. I tried to short it, apply power, wait a few seconds, remove power, remove jumper, reapply power, then connect USB. The printer is not erased, and shows up in the device manager still as the DaVinci Duo.

I am wondering how those that flashed the Duo 2.0 did so?

Thanks
Reply
#14
I tried reverting back from 1.2.3 using your software and windows 7, but the program would just hang while waiting for the printer to update firmware and restart. Yes, I had prepared my, newer davinci (didn't have pads soldered to the J1), for flashing and had the two blacked out lines on the LCD showing. The port was already filled in by the downgrade software program, and matched the one displayed in device manager, I filled in the SSN, and tried both G and J firmaware without success.
I then tried communication with the printer using the insturcions in the DAVINCI_1_0_RESET.zip with the newest arduino 1.0.6 and it did not respond to the on off light test. So, I pulled out a Vista laptop, yes vista, put the bossac.exe and the 3DP01_FW_V1.1.J.bin files under C:/ and ran command prompt with administrative privaledges. and got the J firmware installed. My Vista machine no longer recognised the davinci, so i switched back to the W7 machine and entered my SSN using the arduino interface. and checked it to verify. Hope this helps if you get software bricked....
Reply
#15
:evil: Confusedilly: :pinch: :whistle: okay ......soooooooooi swear you said 1.1.j works on da vinci 2.0 !!!!!!!! Where is my options for second excurder head. !!!!????? Not working plus my ssn is not 3D01P.....MORE LIKE 3F20XPGBXTH48J0238 ...it doesn't add the 3f2ox instead it adds 3d01p I'm not running one head on a $649 purchase. This does it I can wait for yous to help cause I'm not finding any solutions here .....I need 2.0.0 back on my printer..But I'm probably going with repeiter firmware. From what I have read its looking pretty awesome especially sents I can't even print. At all ya xzyware doesn't work totally b4oken. And so it the mod both of them for me anyway man I have to get this done like now !!!!!! I make money and I have orders man !
Reply
#16
Phil's app didnt work for me. I am stuck with 2 solid lines on my printer LCD. I tried the manual solution with RESET_1_0 zip file and this time it doesnt recognise the printer as bossac serial drive instead it says GPS camera.. I dont know what to do , please help. Can i at least turn the printer to the way it was before?
Reply
#17
so you unplug the printer and the gps camera goes away in device manager? If so, just uninstall the gps camera device and manually install the correct driver. Without the correct driver the device will not be seen by the flashing software.

Kieth
Reply
#18
I am getting ready to use the XYZ 1.2.3 Firmware downgrader App. It ask if I have prepared my printer for a firmware flash, I'm not sure what that means. Does it mean I have to jumper the J1 pin before using the app?
Reply
#19
Quote:
Quote:Hi. Sorry for reviving the old topic. I have recently bought a XYZAP v2 PLUS and unfortunately I had upgraded the firmware before knowing it's problems. My DaVinci 1.0 has now the 2.0.1 firmware version and I can't downgrade it, even following the steps in many websites. Does anybody know if there is any way to downgrade it? I would appreciate any help. Thank you.
I assume this utility still works, so all you have to do is remove the back panel of the printer and short JP1 or J37 (have the printer off, connect the pins, and turn the printer on for around 10 seconds). Once you have done that, you should be able to run the software at the top of the page and downgrade the firmware. Tell us how it goes

Hi, I've followed your hint and I've successfully downgraded the firmware. Now, the problem is the printer doesn't recognize the cartridge anymore. I keep getting the message "No cartridge". Any suggestions?
Reply
#20
Phil- It looks like this works for others. Not working for me on 1.0 AiO... Says "Click ok only after restart" but never restarts.. Any ideas?

Thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)